Mac 更新 Node

每次使用 npm 包裝 js、css 時都出現以下訊息。(我都眼不見為淨)

今天打算來處理它,但不知道更新會不會有問題,我這台 Mac 已經買很久了,使用 Homebrew 安裝Nodel.js 它應該是Mac上比較常見的套件管理工具之一,如果以前使用 brew install node 安裝,可以通過以下指令另一個升級到最新的Node.js版本。

brew update
brew upgrade node

後來遇到以下類似的錯誤

CompilerSelectionError: ruby-build cannot be built with any available compilers.
Install GNU's GCC
  brew install gcc

看到以上類似的錯誤,一直照著指示下指令,開始有點迷惘,但執行到以下命令,終於可以用了!

xcode-select --install

發佈留言